by Nicole Yankelovich (nicole@openwonderland.org)



Purpose#

This tutorial provides a basic introduction to Open Wonderland, describing how to navigate and how to use the standard tools that are bundled with the Wonderland release. Your version of Wonderland may have additional features installed, so please check the Help menu for instructions on how to use the extended feature set.

Prerequisites#

This tutorial assumes that someone has already installed Open Wonderland, so for this tutorial, you will need:

  • Access to an Open Wonderland server
  • Link (URL) to the Open Wonderland launch page
  • User name and password if your server is set up with authentication
  • Current version of Java (get Java update)
  • Computer with a graphics card capable of running a 3D application (see system requirements)
  • Microphone and stereo headphones (or a stereo microphone headset)
  • Optionally, 1-3 friends or colleagues to work with

If you decide to do this tutorial with other people, it is essential that each of you wears headphones. Even iPod-style headphones will work. If you have audio coming out of your computer's speakers, bad echo will be introduced into the virtual world, making it very difficult to have a conversation. As long as you are wearing headphones, it's fine if multiple people are in the same room. Just try not to sit too close to one another.

Launching Open Wonderland#

You should have a link to your Open Wonderland installation. It will look something like this:

http://server-name.org.com:8080/

Use your web browser to navigate to this web page. The page will look like this:



Click on the "Launch" button. The first time you run Wonderland, it will take a while for the application to download.



Depending on your operating system, you may see a variety of different dialogs during startup, including one that asks you to "trust" the server. Click through all of these. Start-up time will be considerably faster after the application downloads the first time. Once the download is complete, you see a login screen:



If your screen looks like this one, simply type in your first name in the Username field. This is the name that will appear above your avatar's head, so select the name that you wish other people to call you by. There is no need to modify the two other fields. If authentication is configured on your server, you can either log in as an authenticated user, if you have been given a user name and password, or you may select the "Guest" option and enter only a user name:



Note that if you do have a pre-assigned username, you will not be able to log in as a Guest with this exact name. If you have forgotten your password, simply select a slightly different username and log in as a Guest.

When you click the "Login" button, you will see a series of messages appear in the status area of the login dialog. After a short wait, the dialog will disappear and you should see your avatar. It will initially appear looking like a cartoon. The section Configuring Your Avatar below will explain how to change this.

At this point, you may wish to make your Wonderland window as large as you can given the constraints of your monitor. This will allow you to see more context.

If you are working through the tutorial with other people, you will see their avatars as well as your own.

Navigation#

The first thing you want to do is move your avatar a short distance away from the starting location, otherwise there will be a pile-up when others come into the world. While you are learning to navigate, it is helpful to open the Navigation Reference guide. Select "Navigation Reference" from the Help menu:



Feel free to position the reference window anywhere you wish.

Now, click once on your avatar and try using the up and down arrow keys to move your avatar forward and backwards. For you gamers, the W and S keys will also move you forward and backwards. Now try turning right and left with either the right and left arrow keys, or the A and D keys. The scroll wheel on your mouse or trackpad will zoom your view in and out. This is handy for getting an overview of the scene or for zooming in on a small detail. Holding down the Control key while dragging the mouse up and down is another way to look around at the scene. This allows you to look up at the sky or down at the ground.

Use the up arrow or W key to move to a location with some open space. Experiment with the Q and E keys to step left and right. Now try running forward by holding down the up arrow key and the Shift key at the same time.

It's always fun to do things in the virtual world that you can't do in real life. To fly up into the sky for a birds-eye view of the world, first uncheck "Avatar Gravity Enabled" from the Tools menu. Now click on your avatar and then use the Page Up key to fly up. Once you're up a ways, use the right and left arrow keys to have a look around. You can also use the up arrow key to walk in the air. To fall back to earth, simply select "Avatar Gravity Enabled" again.

Using Placemarks#

Another way to navigate is to use placemarks, which are similar to bookmarks in a web browser. All Wonderland installations will include a "Starting Location" placemark in the Placemarks menu. Other installations may include many more:



Group Text Chat#

In the bottom left corner of your screen, you should see a Text Chat All window:



If you are unable to hear others in the world, you can use this text chat window to communicate. To send a message, click in the bottom pane of the Chat window and type. Click Send or press Enter to send your message to everyone who is logged in to the same Wonderland world.

Setting Up Your Audio#

Getting audio to work can be one of the trickiest parts of using Wonderland.

First find your computer volume setting and adjust it to the 75% level.

If someone else is in the world with you, each of you should try speaking into your microphone. Can you hear each other? If you can't hear one another or if you hear echo, refer to the audio section of the Troubleshooting Guide. If you can hear, take turns talking and providing each other with feedback on how you each sound. It is often necessary to go to your audio control panel and raise or lower your microphone volume, also referred to on some systems as "audio gain."

If you are alone you can use the Audio Recorder to test your audio and fine-tune your settings. Select "Object" from the "Insert" menu. In the dialog that appears, click on the Audio Recorder item and then click the Insert button:



The Audio Recorder should appear at your avatar's feet. You can record yourself speaking a short sentence and the play back the recording to hear how you sound to others. Click on the red record button and speak a short sentence. Click on the middle (black) button to stop the recording. Play back your sentence by clicking on the green play button. If your audio sounds too loud or too soft, use your system audio control panel to raise or lower your microphone volume, also referred to on some systems as "audio gain."

If your audio is not working properly, refer to the audio section of the Troubleshooting Guide for help.

Configuring Your Avatar#

Every new Wonderland user starts out with a cartoon-style avatar. This is a low-fidelity character that works with most graphics systems. If you have a low-end graphics card, this may be the only type of avatar you can use. Before changing your avatar, select "Front Camera" fro the View menu. Now, to change your avatar, select "Configure Avatar" from the Edit menu. In the dialog that appears, you can choose from one of the pre-configured avatars. Select an avatar from the list and click the "Use" button.

To create a new, high-fidelity avatar that is capable of walking and gesturing, click the "New" button in the Configure Avatar dialog:



This configuration dialog allows you to switch gender and change various attributes of your appearance. Other people in the world do not see the changes you are making until your click the "Use" button:



Using Evolver.com

The basic Wonderland distribution only includes minimal choices for configuring your avatar. You can, however, use the Evolver web site to create your avatar. You can upload a photograph of yourself to make a look-alike clone. The site has tools for editing your appearance so you can modify how you look. As shown in the illustration below, you can even edit the clothing to add logos or other designs of your choosing:



Once you have created an avatar or a clone, navigate to the "Transport" section of the web site. Navigate to the "3D Pro / Hobbyist" tab. Scroll down until you see "Pre-tuned Wonderland Avatar" and click on "Build Now." Be sure to select the appropriate male or female skeleton. Once you click through the build pages, you will eventually be given a file to download to your computer. Save this file on your desktop or somewhere that you can find it. You will notice that this file has the .evm extension. To use your Evolver avatar within Wonderland, simply drag and drop the .evm file into an open Wonderland window. The avatar will be uploaded to the Wonderland server and will be installed in the avatar configuration dialog. You will not be able to edit this avatar from within Wonderland, but you will be able to switch to a different avatar and then back to your Evolver avatar.

Gesturing#

With a high fidelity avatar, you can select from a number of different gestures. To view the gestures, select "Gestures" from the Window menu:



Click on the different buttons to animate your avatar. Selecting the "Hide Gestures" button will iconify the set so you can keep them available on your screen. Note that gestures do not work with low fidelity avatars such as the cartoon and toy avatars.

Using the Users Window#

When other users are in the world with you, it's handy to keep the Users window open. Select "Users" from the Window menu and a list similar to this one will appear:

Mute

Text Chat

Voice Chat

Phone

Go To User

Edit User Name

Edit User Properties


Adding Content Using Drag-and-Drop#

The easiest way to add new content to a Wonderland world is to drag and drop it from your desktop or from a web browser. If you find an image on your computer or in a web browser in .jpg, .png, or .gif format, you can simply drag it into an open Wonderland window:



For 3D content, you can drag and drop models in .kmz (Google Earth) or .dae (Collada) format. To find 3D content to experiment with, explore the Google 3D Warehouse. This resource has hundreds of thousands of free 3D models created with the free 3D modeling program, Google SketchUp. There are a number of tutorials in the "For Content Developers" section of the Open Wonderland Documentation Wiki that walk you through the process of creating your own virtual world.

Another type of content you can drag and drop is PDF documents. In a standard Wonderland installation, this will launch a multi-user PDF Viewer:



Initially, you will see the PDF document with a red border. To use this application and all others in Wonderland, right click on the document and select "Take Control" from the context menu;



The border of the window should turn green, indicating that you have control, and a tool palette should appear on your glass pane, known as the HUD or Heads-Up Display. If the tool palette is in-world, click on the left-most icon to bring it to the front:



Like many of the 2D applications in Wonderland, this is a multi-user application. Multiple users may take control of the PDF Viewer at the same time. Typically, one person is the presenter and controls the slides. If someone who is not presenting wishes to browse the slides independently, for example, if they want to go back and review a previously slide, that user may click on the un-sync button (second to last) and browse the slides independently. At any time, they may click again on the same button to synchronize with the presenter.

In order to move your avatar again, you will need to click on the "Release App Control" button in the upper right corner of your screen:



Some installations of Wonderland have multiple applications that can handle the same type of data. For example, your Wonderland installation might have the Presentation tool installed. This allows you to spread out PDF slides rather than just seeing them in a single-frame viewer. If this is the case, you will be given a choice of application to use when you drag and drop:



If you choose the PDF Slide Spreader, your slides will be spread out in front of your avatar:



Adding Content Using the Insert Object Dialog#

Each Wonderland server is configured with a different set of features. To find the list of 2D and 3D applications installed on your server, select "Object" from the "Insert" menu:



Most Wonderland installations come with a simple Whiteboard application. Find "Whiteboard (SVG)" in the list, select it, and click "Insert." This will place a multi-user Whiteboard directly in front of your avatar:



To use this application, and all others in Wonderland, right click on the Whiteboard and select "Take Control" from the context menu:



The red border will turn to green, indicating that you are now controlling this application. Note that any number of people in the world may simultaneously take control of the Whiteboard and draw. This is an example of a multi-user application that allows multiple Wonderland users draw at the same time:



If the tool palette is in-world under the Whiteboard, you can click on the left-most icon to bring the tools up onto the glass pane, known as the HUD or Heads-Up Display. Clicking again on this icon will return the tool palette in-world:



To use the Whiteboard, click on a color and then a tool and draw. The icon between the Text tool and the red paint pot allows you to switch been filled and unfilled objects:



When you are finished using the Whiteboard, you must click on the "Release App Control" button in the upper right corner of your screen. Until you release control, you will not be able to move your avatar.

Add new attachment

Only authorized users are allowed to upload new attachments.

List of attachments

Kind Attachment Name Size Version Date Modified Author Change note
png
ConfigureAvatar-FrontAndNew_00... 100.9 kB 1 18-Apr-2011 10:16 Dave Koelmeyer
png
ConfigureAvatar-FrontAndNew_00... 88.8 kB 2 18-Apr-2011 11:12 Dave Koelmeyer
png
ConfigureAvatar-Summer_001.png 187.5 kB 1 18-Apr-2011 11:12 Dave Koelmeyer
png
ConfigureAvatar-Summer_001_thu... 114.9 kB 1 18-Apr-2011 11:13 Dave Koelmeyer
png
Downloading_001.png 21.9 kB 1 18-Apr-2011 10:03 Dave Koelmeyer
png
Downloading_001_thumb.png 27.8 kB 1 18-Apr-2011 10:33 Dave Koelmeyer
png
Downloading_002.png 21.9 kB 1 18-Apr-2011 10:30 Dave Koelmeyer
png
GestureHUD.png 24.9 kB 1 18-Apr-2011 10:18 Dave Koelmeyer
png
GroupChat.png 36.5 kB 1 18-Apr-2011 10:06 Dave Koelmeyer
png
ImageDrag.png 375.9 kB 1 18-Apr-2011 11:40 Dave Koelmeyer
png
ImageDrag_thumb.png 118.7 kB 1 18-Apr-2011 11:41 Dave Koelmeyer
png
ImageDropped.png 362.6 kB 1 18-Apr-2011 11:41 Dave Koelmeyer
png
ImageDropped_thumb.png 123.4 kB 1 18-Apr-2011 11:41 Dave Koelmeyer
png
InsertObject-AudioRecorder_001... 50.3 kB 1 18-Apr-2011 10:16 Dave Koelmeyer
png
InsertObject-AudioRecorder_001... 41.7 kB 1 18-Apr-2011 11:05 Dave Koelmeyer
png
InsertObjectDialogWB.png 65.9 kB 1 18-Apr-2011 12:07 Dave Koelmeyer
png
OWL-Login-Dialog-Auth.png 45.5 kB 1 18-Apr-2011 10:05 Dave Koelmeyer
png
OWL-Login-Dialog-Auth_001.png 27.4 kB 2 18-Apr-2011 10:41 Dave Koelmeyer
png
OWL-Login-Dialog-Auth_001_thum... 45.5 kB 1 18-Apr-2011 10:41 Dave Koelmeyer
png
OWL-Login-Dialog-NoAuth.png 37.6 kB 1 18-Apr-2011 10:04 Dave Koelmeyer
png
OWL-Login-Dialog-NoAuth_001_th... 37.6 kB 1 18-Apr-2011 10:37 Dave Koelmeyer
png
OWL-Web-StartPage.png 138.1 kB 1 18-Apr-2011 10:20 Dave Koelmeyer
png
OWL-Web-StartPage_thumb.png 89.8 kB 1 18-Apr-2011 10:04 Dave Koelmeyer
png
PDF-Chooser.png 12.2 kB 1 18-Apr-2011 11:47 Dave Koelmeyer
png
PDF-Spreader.png 563.7 kB 1 18-Apr-2011 11:49 Dave Koelmeyer
png
PDF-Spreader_thumb.png 187.2 kB 1 18-Apr-2011 11:50 Dave Koelmeyer
png
PDF-Viewer-Release.png 26.7 kB 1 18-Apr-2011 11:46 Dave Koelmeyer
png
PDF-Viewer1.png 402.2 kB 1 18-Apr-2011 11:40 Dave Koelmeyer
png
PDF-Viewer1_thumb.png 141.9 kB 1 18-Apr-2011 11:40 Dave Koelmeyer
png
PDF-Viewer2.png 409.2 kB 1 18-Apr-2011 11:46 Dave Koelmeyer
png
PDF-Viewer2_thumb.png 146.5 kB 1 18-Apr-2011 11:46 Dave Koelmeyer
png
PDF-Viewer3.png 432.3 kB 1 18-Apr-2011 11:45 Dave Koelmeyer
png
PDF-Viewer3_thumb.png 152.8 kB 1 18-Apr-2011 11:45 Dave Koelmeyer
png
Placemark-6.png 248.0 kB 1 18-Apr-2011 10:07 Dave Koelmeyer
png
Placemark-6_thumb.png 90.0 kB 1 18-Apr-2011 10:07 Dave Koelmeyer
png
UserListChatText24x24.png 1.2 kB 1 18-Apr-2011 11:18 Dave Koelmeyer
png
UserListChatVoice24x24.png 1.4 kB 1 18-Apr-2011 11:19 Dave Koelmeyer
png
UserListEdit24x24.png 1.5 kB 1 18-Apr-2011 11:19 Dave Koelmeyer
png
UserListFull2.png 18.9 kB 1 18-Apr-2011 10:18 Dave Koelmeyer
png
UserListGoto24x24.png 1.4 kB 2 18-Apr-2011 11:19 Dave Koelmeyer
png
UserListMuteOff24x24.png 1.5 kB 1 18-Apr-2011 11:19 Dave Koelmeyer
png
UserListPhone24x24.png 1.3 kB 1 18-Apr-2011 11:19 Dave Koelmeyer
png
UserListProperties24x24.png 1.0 kB 1 18-Apr-2011 11:19 Dave Koelmeyer
png
WhiteboardJustInserted.png 140.6 kB 1 18-Apr-2011 12:13 Dave Koelmeyer
png
WhiteboardJustInserted_thumb.p... 61.7 kB 1 18-Apr-2011 12:13 Dave Koelmeyer
png
WhiteboardReleaseControl.png 152.9 kB 1 18-Apr-2011 12:14 Dave Koelmeyer
png
WhiteboardReleaseControl_thumb... 70.9 kB 1 18-Apr-2011 12:18 Dave Koelmeyer
png
WhiteboardSelectPalette.png 149.9 kB 1 18-Apr-2011 12:18 Dave Koelmeyer
png
WhiteboardSelectPalette_thumb.... 65.9 kB 1 18-Apr-2011 12:37 Dave Koelmeyer
png
WhiteboardSelectRect.png 143.5 kB 1 18-Apr-2011 12:18 Dave Koelmeyer
png
WhiteboardSelectRect_thumb.png 65.6 kB 1 18-Apr-2011 12:18 Dave Koelmeyer
png
WhiteboardTakeControl.png 149.8 kB 1 18-Apr-2011 12:19 Dave Koelmeyer
png
WhiteboardTakeControl_thumb.pn... 68.7 kB 1 18-Apr-2011 12:19 Dave Koelmeyer
png
WonderlandGirl1.png 40.8 kB 1 18-Apr-2011 10:18 Dave Koelmeyer
png
quickref.png 42.8 kB 1 18-Apr-2011 10:06 Dave Koelmeyer
png
quickref_thumb.png 45.3 kB 1 18-Apr-2011 10:06 Dave Koelmeyer
« This page (revision-34) was last changed on 21-Sep-2015 09:07 by Abhishek Upadhyay